File: changelog

package info (click to toggle)
vis 0.6-3
  • links: PTS, VCS
  • area: main
  • in suites: bullseye, sid
  • size: 12,408 kB
  • sloc: ansic: 22,036; sh: 910; makefile: 328; python: 45
file content (130 lines) | stat: -rw-r--r-- 4,699 bytes parent folder | download
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83
84
85
86
87
88
89
90
91
92
93
94
95
96
97
98
99
100
101
102
103
104
105
106
107
108
109
110
111
112
113
114
115
116
117
118
119
120
121
122
123
124
125
126
127
128
129
130
vis (0.6-3) unstable; urgency=medium

  * Run the tests only on: amd64, arm64, ppc64el.

 -- Paride Legovini <paride@debian.org>  Wed, 29 Jul 2020 22:59:29 +0000

vis (0.6-2) unstable; urgency=medium

  * d/control: Build-Depend on vim and 9base only on amd64 due to
    package availability and flaky tests.
  * d/gbp.conf: move the pristine-tar settings to the DEFAULT section.

 -- Paride Legovini <paride@debian.org>  Tue, 07 Jul 2020 18:17:56 +0000

vis (0.6-1) unstable; urgency=medium

  * New upstream version 0.6.
  * d/control:
    - Bump Standards-Version to 4.5.0 (no changes needed).
    - Bump the dh compat level to 13.
    - Build-Depend on 9base and vim (needed test against sam and vim).
    - Use the paride@debian.org alias in Uploaders.
    - Add Multi-Arch: foreign.
    - Add Rules-Requires-Root: no.
    - Rewrap the file (wrap-and-sort -st).
  * d/gbp.conf:
    - Unset upstream-branch (imports are done from upstream git).
    - Always create the (xz compressed) pristine-tar.
  * d/rules:
    - Re-enable the vim tests.
    - Stop enforcing -Wl,--as-needed (now done by default).
    - Drop the test suite cleanup commands; use d/clean instead.
    - dh_auto_test: set LANG=C.UTF-8.
      See: https://github.com/martanne/vis-test/issues/25.
  * d/copyright: update copyright entry for debian/*.
  * autopkgtests:
    - Drop the needs-recommends requirement (deprecated).
    - Do not set LC_ALL=en_US.UTF-8 (now done upstream).
  * Drop all the patches (upstreamed).

 -- Paride Legovini <paride@debian.org>  Mon, 06 Jul 2020 22:33:26 +0000

vis (0.5+ts-3) unstable; urgency=medium

  * Disable the vim tests
  * Run the test/vis tests as autopkgtest

 -- Paride Legovini <pl@ninthfloor.org>  Tue, 08 May 2018 14:34:19 +0000

vis (0.5+ts-2) unstable; urgency=medium

  * Build-depend on libselinux1-dev only on Linux systems

 -- Paride Legovini <pl@ninthfloor.org>  Mon, 16 Apr 2018 21:46:38 +0000

vis (0.5+ts-1) unstable; urgency=medium

  * Enable the test suite (git submodule):
    - d/rules: do not override_dh_auto_test.
    - d/rules: cleanup the test suite after building.
    - d/gbp.conf: add ‘submodules = True’.
    - New build-deps: locales-all, lua-busted, lua-lpeg, vim.
    - Cover the test suite in d/copyright.
    - Add the ‘+ts’ version string to differentiate the new .orig
      tarball now containing the test suite from the previous one.
    - Patch: delete broken test depending on external sed(1)
      invocation (cherry-pick, upstream commit 90dd04f).
    - Patch: make sure $TERM is set (cherry pick, c824ec2).
  * Build with POSIX acl support (build-depend on libacl1-dev).
  * Build with SELinux support (build-depend on libselinux1-dev).
  * Bump Standards-Version to 4.1.4 (no changes needed).
  * debian/* relicensed as ISC.
  * d/watch: dversionmangle: remove version string

 -- Paride Legovini <pl@ninthfloor.org>  Mon, 16 Apr 2018 08:41:36 +0000

vis (0.5-1) unstable; urgency=medium

  * New upstream version 0.5
  * Drop upstreamed patches
  * New patches:
    - Remove execution file permission from clojure.lua
      (upstreamed, cherry-picked)
    - Remove broken manpage POSIX referemce
      (upstreamed, cherry-picked)
  * Add upstream metadata file (DEP12)
  * debian/copyright:
    - updated copyright years
    - added the new lexers
    - lexers copyright entries consolidated in a single section
    - point to ‘common-licenses’ instead of reporting the full CC0 license

 -- Paride Legovini <pl@ninthfloor.org>  Wed, 28 Mar 2018 07:19:54 +0000

vis (0.4-2) unstable; urgency=medium

  * Bump to Standards-Version 4.1.3
  * Bump compat level to 11
  * Packaging repository moved to salsa
  * Only link with needed libraries (ld --as-needed)

 -- Paride Legovini <pl@ninthfloor.org>  Mon, 19 Feb 2018 18:13:23 +0100

vis (0.4-1) unstable; urgency=medium

  * New upstream version
  * Bump debian/compat level to 10
  * Remove upstreamed patches
  * Patch the missing copyright notice for the strace lexer
  * Add debian/copyright entry for the strace lexer
  * Bump standards version
  * Remove extra license files
  * Add more options to d/gbp.conf
  * Add Vcs- fields to d/control
  * Specify the packaging branch in the Vcs-Git field
  * Fix d/gbp.conf (options must be specified without the 'git-' prefix)

 -- Paride Legovini <pl@ninthfloor.org>  Tue, 25 Jul 2017 15:22:33 +0200

vis (0.3-2) unstable; urgency=medium

  * Fix compilation on GNU Hurd systems (Closes: #860513)

 -- Paride Legovini <pl@ninthfloor.org>  Sat, 13 May 2017 12:29:13 +0200

vis (0.3-1) unstable; urgency=medium

  * Initial release. (Closes: #838895)

 -- Paride Legovini <pl@ninthfloor.org>  Fri, 31 Mar 2017 16:00:13 +0200