1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57
|
export DEB_BUILD_MAINT_OPTIONS = hardening=+bindnow
export DEB_LDFLAGS_MAINT_APPEND = -Wl,--as-needed
export WEBAUTH_PERL_FLAGS := --installdirs vendor --create_packlist 0
export AUTOMATED_TESTING := 1
ifndef PERL
PERL = /usr/bin/perl
endif
PERL_VENDORARCH := $(shell perl -MConfig -e 'print $$Config{vendorarch}')
%:
dh $@ --parallel --with apache2,autoreconf
override_dh_autoreconf:
dh_autoreconf --as-needed
override_dh_auto_configure:
dh_auto_configure --parallel -- --libexecdir=/usr/lib \
--enable-webkdc --enable-perl --with-apxs=/usr/bin/apxs \
--enable-reduced-depends
override_dh_auto_install:
dh_auto_install
chmod a+x debian/tmp/usr/share/weblogin/*.fcgi
mkdir -p debian/tmp/usr/share/perl5
mv debian/tmp$(PERL_VENDORARCH)/WebKDC* debian/tmp/usr/share/perl5
mv debian/tmp$(PERL_VENDORARCH)/WebLogin* debian/tmp/usr/share/perl5
override_dh_installchangelogs:
dh_installchangelogs NEWS
override_dh_fixperms:
dh_fixperms
set -e; if [ -d 'debian/libwebkdc-perl/var/cache/weblogin' ] ; then \
chown www-data:www-data debian/libwebkdc-perl/var/cache/weblogin; \
fi
override_dh_apache2:
dh_apache2 -Nlibapache2-mod-webauth -Nlibapache2-mod-webauthldap
dh_apache2 -plibapache2-mod-webauth -e
dh_apache2 -plibapache2-mod-webauthldap -e
|