File: changelog

package info (click to toggle)
writer2latex 1.4-8
  • links: PTS, VCS
  • area: main
  • in suites: buster, sid
  • size: 4,732 kB
  • sloc: java: 31,558; xml: 4,703; makefile: 73; sh: 38
file content (334 lines) | stat: -rw-r--r-- 10,759 bytes parent folder | download
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83
84
85
86
87
88
89
90
91
92
93
94
95
96
97
98
99
100
101
102
103
104
105
106
107
108
109
110
111
112
113
114
115
116
117
118
119
120
121
122
123
124
125
126
127
128
129
130
131
132
133
134
135
136
137
138
139
140
141
142
143
144
145
146
147
148
149
150
151
152
153
154
155
156
157
158
159
160
161
162
163
164
165
166
167
168
169
170
171
172
173
174
175
176
177
178
179
180
181
182
183
184
185
186
187
188
189
190
191
192
193
194
195
196
197
198
199
200
201
202
203
204
205
206
207
208
209
210
211
212
213
214
215
216
217
218
219
220
221
222
223
224
225
226
227
228
229
230
231
232
233
234
235
236
237
238
239
240
241
242
243
244
245
246
247
248
249
250
251
252
253
254
255
256
257
258
259
260
261
262
263
264
265
266
267
268
269
270
271
272
273
274
275
276
277
278
279
280
281
282
283
284
285
286
287
288
289
290
291
292
293
294
295
296
297
298
299
300
301
302
303
304
305
306
307
308
309
310
311
312
313
314
315
316
317
318
319
320
321
322
323
324
325
326
327
328
329
330
331
332
333
334
writer2latex (1.4-8) unstable; urgency=medium

  * remove code changes of no_JSON.diff and use libandroid-json-java.
  * move more java5-runtime to java6-runtimes

 -- Rene Engelhard <rene@debian.org>  Sun, 04 Nov 2018 21:51:10 +0100

writer2latex (1.4-7) unstable; urgency=medium

  * Revert "remove code changes of no_JSON.diff and use libandroid-json-java"
    for now...

 -- Rene Engelhard <rene@debian.org>  Sun, 04 Nov 2018 20:59:52 +0100

writer2latex (1.4-6) unstable; urgency=medium

  * build-depend on libjaxb-java and add jaxb-api.jar to main.class.path,
    thanks Emmanuel Bourg for the hint (closes: #912270)
  * remove code changes of no_JSON.diff and use libandroid-json-java
  * java2-runtime -> java6-runtime in Depends:...

 -- Rene Engelhard <rene@debian.org>  Sun, 04 Nov 2018 18:47:00 +0000

writer2latex (1.4-5) unstable; urgency=medium

  * also update libreoffice-writer2xhtml...

 -- Rene Engelhard <rene@debian.org>  Mon, 23 Apr 2018 12:02:18 +0200

writer2latex (1.4-4) unstable; urgency=medium

  * update Vcs-* to salsa
  * remove g(c|i)j alternatives in Depends:

 -- Rene Engelhard <rene@debian.org>  Sun, 22 Apr 2018 17:52:22 +0000

writer2latex (1.4-3) unstable; urgency=medium

  * debian/patches/no-built-by.diff: don't write Built-By: into the manifest
    so that the build really gets reproducible

 -- Rene Engelhard <rene@debian.org>  Wed, 16 Aug 2017 20:54:15 +0000

writer2latex (1.4-2) unstable; urgency=medium

  * use <arg value="-notimestamp"/> for javadoc to make them
    reproducible (closes: #860098)
  * bump debian/compat to 9

 -- Rene Engelhard <rene@debian.org>  Sat, 27 May 2017 11:35:24 +0200

writer2latex (1.4-1) unstable; urgency=medium

  * New upstream release

  * use default-jdk as we require Java 6 now

  * debian/patches/no-JSON.diff: don't require org.JSON which is under
    the "shall be used for Good, not Evil." clause... (and therefore
    removed from the orig)
  * move from dpatch to 3.0 (quilt)

 -- Rene Engelhard <rene@debian.org>  Wed, 23 Dec 2015 21:48:37 +0100

writer2latex (1.0.2-10) unstable; urgency=low

  * upload to unstable 

 -- Rene Engelhard <rene@debian.org>  Fri, 19 Apr 2013 00:59:31 +0200

writer2latex (1.0.2-9) experimental; urgency=low

  * "steal" patch from RedHat to adapt to LO 4.0 API Changes 

 -- Rene Engelhard <rene@debian.org>  Mon, 01 Apr 2013 19:08:45 +0200

writer2latex (1.0.2-8) unstable; urgency=medium

  * Fix build with LibreOffice 3.5, thanks Colin Watson (closes: #669423)

 -- Rene Engelhard <rene@debian.org>  Fri, 20 Apr 2012 01:07:04 +0200

writer2latex (1.0.2-7) unstable; urgency=low

  * remove obsolete debian/po (closes: #619659) 
  * install source/java/writer2latex/xhtml/config/*.xml,
    thanks Samuel Thibault (closes: #639736) 

 -- Rene Engelhard <rene@debian.org>  Mon, 23 Jan 2012 22:05:34 +0100

writer2latex (1.0.2-6) unstable; urgency=high

  * fix build with LibreOffice 3.4 

 -- Rene Engelhard <rene@debian.org>  Mon, 12 Sep 2011 17:10:58 +0200

writer2latex (1.0.2-5) unstable; urgency=low

  * remove spaces at the end of package descriptions (closes: #614214)
  * fix convertingconverts (closes: #618772, #618773)

 -- Rene Engelhard <rene@debian.org>  Fri, 18 Mar 2011 15:54:23 +0100

writer2latex (1.0.2-4) unstable; urgency=low

  * fix/update package descriptions (closes: #613577, #613579) 
  * add Vcs-{Git,Browser} 

 -- Rene Engelhard <rene@debian.org>  Fri, 18 Feb 2011 14:24:24 +0000

writer2latex (1.0.2-3) unstable; urgency=low

  * upload to unstable 

 -- Rene Engelhard <rene@debian.org>  Sun, 06 Feb 2011 11:19:28 +0000

writer2latex (1.0.2-2) experimental; urgency=low

  * change maintainer to Debian LibreOffice Maintainers
  * don't gzip .odt files (closes: #610311) 
  * don't predefine printer settings and name (PrinterSetup and
    PrinterName in settings.xml) in user-manual.odt (closes: #610312)
  * rename to libreoffice-writer2* and install them unpacked
  * remove Pre-Depends; now finally not needed anymore, yay 

 -- Rene Engelhard <rene@debian.org>  Wed, 19 Jan 2011 23:11:06 +0100

writer2latex (1.0.2-1) unstable; urgency=low

  * new upstream release 
  * remove check_for_running_ooo as for OOo itself 

 -- Rene Engelhard <rene@debian.org>  Mon, 22 Nov 2010 00:44:13 +0100

writer2latex (1.0-12) unstable; urgency=medium

  * hack: remove Pre-Depends on openoffice.org-java-common  again, add
    to Depends: instead (see #571771). The gack from 1.0-6 also still
    needed

 -- Rene Engelhard <rene@debian.org>  Sun, 25 Apr 2010 23:56:47 +0200

writer2latex (1.0-11) unstable; urgency=low

  * revert back to build-depending on ant, as ant is now fixed;
    add build-conflicts against ant 1.8.0-{1,2,3}

 -- Rene Engelhard <rene@debian.org>  Tue, 16 Mar 2010 01:03:04 +0100

writer2latex (1.0-10) unstable; urgency=low

  * build-depend on ant1.7 | ant (<< 1.8.0~) (closes: #571397)

 -- Rene Engelhard <rene@debian.org>  Thu, 04 Mar 2010 18:06:03 +0100

writer2latex (1.0-9) unstable; urgency=low

  * update for OOo 3.2 

 -- Rene Engelhard <rene@debian.org>  Thu, 11 Feb 2010 13:10:20 +0100

writer2latex (1.0-8) unstable; urgency=low

  * oops, actually build with -15...

 -- Rene Engelhard <rene@debian.org>  Mon, 08 Feb 2010 01:06:23 +0100

writer2latex (1.0-7) unstable; urgency=low

  * fix clean install to not split out dpkg --compare-versions
    warning (closes: #568713) 
  * restore lost bits in preinst (closes: #568805) 

 -- Rene Engelhard <rene@debian.org>  Mon, 08 Feb 2010 00:55:26 +0100

writer2latex (1.0-6) unstable; urgency=low

  * add missing Pre-Depends on Java and openoffice.org-java-common
  * as the Pre-Depends on -java-common doesn't prevent -common being
    temporarily removed in the upgrade (and we don't have unopkg then...)
    try to recover in postinst from preinst not de-registering the old
    extension.

 -- Rene Engelhard <rene@debian.org>  Sat, 06 Feb 2010 23:13:59 +0100

writer2latex (1.0-5) unstable; urgency=medium

  * stop pre-depending on openoffice.org-common for openoffice.org/running.
    This closes: #566644.
    Rename to shared/openofficeorg-running and merge here.
  * add echos instead of debconf message on DEBIAN_FRONTEND = noninteractive
    so that people in that case also know what goes on
  * remove unneeded postrms, dh_installdebconf already does it for us 
  * fix debian/NEWS to have correct version number; thanks lintian 
  * rebuild with openoffice.org-dev 1:3.1.1-15 

 -- Rene Engelhard <rene@debian.org>  Wed, 27 Jan 2010 09:15:59 +0100

writer2latex (1.0-4) unstable; urgency=medium

  * rebuild with OOo 3.1.1-14 to get a uncorrupted .rdb
  * add missing .lock to find_running_ooo to actually check for the extistence
    of the lockfile and not for the profile dir, thanks Chris Cheney
  * adapt for java-gcj-compat-dev -> gcj-jdk

 -- Rene Engelhard <rene@debian.org>  Fri, 15 Jan 2010 17:15:17 +0100

writer2latex (1.0-3) unstable; urgency=low

  * debian/openoffice.org-writer2latex.prerm: actually source confmodule... 

 -- Rene Engelhard <rene@debian.org>  Mon, 19 Oct 2009 12:02:01 +0200

writer2latex (1.0-2) unstable; urgency=low

  * check whether OOo is running and show error openoffice.org/running if it
    is - as in openoffice.org-common. pre-depend on
    openoffice.org-common (>= 1:3.1.1-3), debconf (>= 0.5) | debconf-2.0
    and procps. (closes: #527556)

 -- Rene Engelhard <rene@debian.org>  Sun, 04 Oct 2009 15:13:38 +0200

writer2latex (1.0-1) unstable; urgency=low

  * New upstream release
  * run unopkg with -v 

 -- Rene Engelhard <rene@debian.org>  Wed, 30 Sep 2009 02:33:25 +0200

writer2latex (1.0~beta3-1) experimental; urgency=low

  * New upstream release

 -- Rene Engelhard <rene@debian.org>  Mon, 27 Apr 2009 18:29:55 +0200

writer2latex (1.0~beta2-1) experimental; urgency=low

  * New upstream release
  * update Homepage:
  * use /var/lib/openoffice/javasettingsunopkginstall.xml for
    -env:UNO_JAVA_JFW_INSTALL_DATA
  * adapt section of libwriter2latex-java: -> java 

 -- Rene Engelhard <rene@debian.org>  Wed, 15 Apr 2009 18:39:20 +0200

writer2latex (0.5.0.2-4) unstable; urgency=low

  * add missing Build-Depends: on ure (closes: #521945) 

 -- Rene Engelhard <rene@debian.org>  Tue, 31 Mar 2009 00:47:44 +0200

writer2latex (0.5.0.2-3) unstable; urgency=high

  * $ORIGIN -> $OOO_BASE_DIR 

 -- Rene Engelhard <rene@debian.org>  Tue, 03 Mar 2009 02:46:26 +0100

writer2latex (0.5.0.2-2) unstable; urgency=low

  * upload to unstable

 -- Rene Engelhard <rene@debian.org>  Fri, 13 Feb 2009 10:03:12 +0100

writer2latex (0.5.0.2-1) experimental; urgency=low

  * New upstream release
  * lintian fixes 

 -- Rene Engelhard <rene@debian.org>  Mon, 06 Oct 2008 02:00:55 +0200

writer2latex (0.5.0.1-fix1-1) experimental; urgency=low

  * New upstream release
    - splits the writer2xhtml part into an own extension
  * debian/patches/01_dirs.dpatch: make generic to work with OOo 2.4.1 and
    3.0.0

 -- Rene Engelhard <rene@debian.org>  Tue, 29 Jul 2008 16:22:15 +0200

writer2latex (0.5-8) unstable; urgency=high

  * add missing Depends: on ${misc:Depends} for writer2latex
    (closes: #490138) 

 -- Rene Engelhard <rene@debian.org>  Fri, 11 Jul 2008 00:28:21 +0200

writer2latex (0.5-7) unstable; urgency=high

  * fix debian/copyright; ooomath.sty is LPPL, actually mention that

 -- Rene Engelhard <rene@debian.org>  Wed, 09 Jul 2008 15:40:16 +0200

writer2latex (0.5-6) unstable; urgency=low

  * add missing -env:JFW_PLUGIN_DO_NOT_CHECK_ACCESSIBILITY=1 to the prerm
    unopkg call, hopefully closes: #468202, please reopen if not 

 -- Rene Engelhard <rene@debian.org>  Thu, 28 Feb 2008 14:11:44 +0100

writer2latex (0.5-5) unstable; urgency=low

  * build-depend on openoffice.org-java-common (closes: #46760) 

 -- Rene Engelhard <rene@debian.org>  Tue, 26 Feb 2008 15:53:46 +0100

writer2latex (0.5-4) unstable; urgency=low

  * upload to unstable
  * add bug script running unopkg list

 -- Rene Engelhard <rene@debian.org>  Fri, 15 Feb 2008 12:37:10 +0100

writer2latex (0.5-3) experimental; urgency=low

  * debian/shell-lib.sh:
    - run unopkg with -env:JFW_PLUGIN_DO_NOT_CHECK_ACCESSIBILITY=1 because
      otherwise the first run with gcj won't find a JRE (and might fail the
      install then). Flush the cache after removing as unopkg doesn't remove
      files on uninstall but marks them as "to-be-removed-on-next-start".
      Thanks Caolan McNamara.

 -- Rene Engelhard <rene@debian.org>  Tue, 04 Dec 2007 17:31:46 +0100

writer2latex (0.5-2) experimental; urgency=low

  * run dh_installtex 

 -- Rene Engelhard <rene@debian.org>  Mon, 26 Nov 2007 14:12:01 +0100

writer2latex (0.5-1) experimental; urgency=low

  * Initial release

 -- Rene Engelhard <rene@debian.org>  Mon, 26 Nov 2007 10:06:34 +0100