File: changelog

package info (click to toggle)
wyrd 1.4.6-4
  • links: PTS
  • area: main
  • in suites: bullseye, buster, sid, stretch
  • size: 1,820 kB
  • ctags: 1,969
  • sloc: ml: 11,059; sh: 5,531; ansic: 760; makefile: 304; python: 44
file content (253 lines) | stat: -rw-r--r-- 8,195 bytes parent folder | download
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83
84
85
86
87
88
89
90
91
92
93
94
95
96
97
98
99
100
101
102
103
104
105
106
107
108
109
110
111
112
113
114
115
116
117
118
119
120
121
122
123
124
125
126
127
128
129
130
131
132
133
134
135
136
137
138
139
140
141
142
143
144
145
146
147
148
149
150
151
152
153
154
155
156
157
158
159
160
161
162
163
164
165
166
167
168
169
170
171
172
173
174
175
176
177
178
179
180
181
182
183
184
185
186
187
188
189
190
191
192
193
194
195
196
197
198
199
200
201
202
203
204
205
206
207
208
209
210
211
212
213
214
215
216
217
218
219
220
221
222
223
224
225
226
227
228
229
230
231
232
233
234
235
236
237
238
239
240
241
242
243
244
245
246
247
248
249
250
251
252
253
wyrd (1.4.6-4) unstable; urgency=medium

  * Get date from changelog for version.ml to make package autobuildable.
  * New patch to fix manpages.

 -- Rhonda D'Vine <rhonda@debian.org>  Mon, 18 Jan 2016 01:09:37 +0100

wyrd (1.4.6-3) unstable; urgency=medium

  [ Mehdi Dogguy ]
  * Use dh-ocaml to compute dependencies
  * Use packaged version of ocaml-curses

  [ Bernd Zeimetz ]
  * Remove further references to embedded curses

 -- Rhonda D'Vine <rhonda@debian.org>  Fri, 27 Nov 2015 15:01:44 +0100

wyrd (1.4.6-2) unstable; urgency=medium

  * Uups.  The fix for #526901 was b0rked.  Reverted that and re-opened the
    bugreport.

 -- Rhonda D'Vine <rhonda@debian.org>  Thu, 26 Nov 2015 13:54:02 +0100

wyrd (1.4.6-1) unstable; urgency=medium

  * New upstream release (closes: #615982), which fixes:
    - FTBFS with newer ocaml (closes: #735832)
    - Typos in manpage fixed (closes: #561543)
    - Updated CONTACT INFO (closes: #481233)
  * Convert debian/rules to dh style and source 3.0 (quilt).  Thanks to bzed
    and weasel for help with that.
  * Added some additional suggestions from Jari Aalto (closes: #670194)
  * Bump compat to 9, Standards-Version to 3.9.6.
  * Add debian/source/format, switch debian/patches to quilt.
  * Use sensible-editor instead of ${VISUAL:-EDITOR} in wyrdrc
    (closes: #616157)
  * Support $DOTREMINDERS in the default wyrdrc (closes: #526901)
  * Adding myself to Uploaders.

 -- Rhonda D'Vine <rhonda@debian.org>  Thu, 26 Nov 2015 11:12:23 +0100

wyrd (1.4.4-1) unstable; urgency=low

  * New upstream release that address temporary file vulnerability
    (CVE-2008-0806). Patch in version 1.4.3b-4 that addresses this
    vulnerabililty (debian bug 466382) removed.
  * Updated Homepage address in debian/control, debian/copyright.
  * Updated watch file.
  * Add libncursesw5-dev to Build-Depends to permit --enable-utf8 configure
    flag to be used. Also add DEB_CONFIGURE_EXTRA_FLAGS = --enable-utf8 to
    debian/rules. Thanks to Jeremy Bobbio. Closes: #446634.

 -- Kevin Coyner <kcoyner@debian.org>  Fri, 22 Feb 2008 16:30:36 -0500

wyrd (1.4.3b-4) unstable; urgency=low

  * Patch from Nico Golde and the security team.
    This patch addresses the following issue:
    CVE-2008-0806: insecure temporary file creation that
    could lead to symlink attacks and thus data loss. Closes: #466382.
  * Bumped Standards-Version to 3.7.3. No changes.
  * Moved Homepage header out of extended description.
  * Removed unnecessary whitespace in doc-base file.

 -- Kevin Coyner <kcoyner@debian.org>  Thu, 21 Feb 2008 17:57:30 -0500

wyrd (1.4.3b-3) unstable; urgency=low

  * Fixed debian/watch file.

 -- Kevin Coyner <kcoyner@debian.org>  Sat, 15 Sep 2007 14:08:57 -0400

wyrd (1.4.3b-2) unstable; urgency=low

  * Add Build-Depends on camlp4, which moved from ocaml-nox's Build-Depends to
    Recommends. Closes a FTBFS bug. Closes: #441503. Removed Build-Depends on
    ocaml-nox and ocaml since camlp4 depends on ocaml-nox.

 -- Kevin Coyner <kcoyner@debian.org>  Sat, 15 Sep 2007 13:31:54 -0400

wyrd (1.4.3b-1) unstable; urgency=low

  * New upstream release.
  * Support for the environment variable DOT_REMINDERS. Closes: #381959.

 -- Kevin Coyner <kcoyner@debian.org>  Wed, 22 Aug 2007 09:33:10 -0400

wyrd (1.4.2-2) unstable; urgency=low

  * New e-mail address for maintainer. Changed throughout debian/*.
  * Update debian/menu from Apps/Tools to Applications/Data Management.
  * Remove some cruft in patches/01_editor.

 -- Kevin Coyner <kcoyner@debian.org>  Tue, 14 Aug 2007 13:51:28 -0400

wyrd (1.4.2-1) unstable; urgency=low

  * New upstream release (support rendering UTF-8 reminders, add the
    untimed_window_width rcfile option). Closes: #431815
  * debian/rules - changed use of $(PWD) to preferred $(CURDIR).
  * debian/README.Debian - added paragraph about checking for new config file
    options that might be available after some of the new upstream releases.

 -- Kevin Coyner <kevin@rustybear.com>  Thu, 05 Jul 2007 06:55:41 -0400

wyrd (1.4.1-3) unstable; urgency=low

  * Apply patch from Frank Terbeck that allows the user to set $EDITOR and
    $VISUAL separately if so desired. Closes: #400576
  * Add dpatch as a Build-Depends in debian/control.
  * Add appropriate dpatch commands to debian/rules.

 -- Kevin Coyner <kevin@rustybear.com>  Mon, 25 Dec 2006 22:18:45 -0500

wyrd (1.4.1-2) unstable; urgency=low

  * New maintainer. Closes: #388429
  * Updated debhelper compatibility level to 5.
  * Added lines to debian/rules to remove cruft post-build.

 -- Kevin Coyner <kevin@rustybear.com>  Wed, 27 Sep 2006 19:45:33 -0400

wyrd (1.4.1-1) unstable; urgency=low

  * New upstream release with mostly bugfixes

 -- René van Bevern <rvb@debian.org>  Wed, 19 Jul 2006 10:04:51 +0200

wyrd (1.4.0-1) unstable; urgency=low

  * New upstream release with minor feature enhancements
  
    + added "default" color specifier
  
    + minimum terminal height is now 23, so that there is place for a
      status bar (e.g. screen)
  
    + "Quick Reminder" command allows users to describe the event using
      english language
  
  * debian/control:
  
    + update my E-Mail address
  
    + push Standards-Version to 3.7.2 without any changes
  
  * debian/rules: delete superfluous /usr/share/doc/wyrd/README

 -- René van Bevern <rvb@debian.org>  Tue, 27 Jun 2006 07:01:05 +0200

wyrd (1.3.0-1) unstable; urgency=low

  * New upstream release
  
  * debian/control: add remind (>= 03.00.24) to Build-Depends, the
    configure script wants to check for the used remind version

  * Upload sponsored by Norbert Tretkowski <nobse@debian.org>

 -- René van Bevern <rvb@progn.org>  Mon, 27 Feb 2006 14:23:58 +0100

wyrd (1.2.0-1) unstable; urgency=low

  * New upstream
  * debian/control: depend on remind 03.00.24
  
  * Upload sponsored by Norbert Tretkowski <nobse@debian.org>

 -- René van Bevern <rvb@pro-linux.de>  Sun, 20 Nov 2005 21:24:31 +0100

wyrd (1.1.1-1) unstable; urgency=low

  * New upstream release
  * debian/control: drop dependency on bsdmainutils, new release does not
    use "cal" anymore

  * Upload sponsored by Norbert Tretkowski <nobse@debian.org>
  
 -- René van Bevern <rvb@pro-linux.de>  Thu, 22 Sep 2005 09:32:54 +0200

wyrd (1.1.0-1) unstable; urgency=low

  * New upstream release
  * added watch file
  * debian/copyright: update FSF address

  * Upload sponsored by Norbert Tretkowski <nobse@debian.org>
  
 -- René van Bevern <rvb@pro-linux.de>  Fri, 16 Sep 2005 18:41:59 +0200

wyrd (1.0.0-1) unstable; urgency=low

  * New upstream version
  * use CDBS
  * updated to Debian policy 3.6.2.1

  * Upload sponsored by Norbert Tretkowski <nobse@debian.org>

 -- René van Bevern <rvb@pro-linux.de>  Sun, 26 Jun 2005 18:19:31 +0200

wyrd (0.3.0-3) unstable; urgency=low

  * Removed my manual page from the source package also

 -- René van Bevern <rvb@pro-linux.de>  Wed, 25 May 2005 11:36:48 +0200

wyrd (0.3.0-2) unstable; urgency=low

  * Closes: #309626: Error when setting the week_starts_monday
    configuration variable
  * changed e-mail address in debian/copyright
  * add homepage to description

 -- René van Bevern <rvb@pro-linux.de>  Sat, 21 May 2005 16:26:34 +0200

wyrd (0.3.0-1) unstable; urgency=low

  * New upstream version
  * removed Debian manpage, upstream has one now
  * register new wyrd documentation with doc-base

 -- René van Bevern <rvb@pro-linux.de>  Thu,  5 May 2005 08:32:42 +0200

wyrd (0.2.0-1) unstable; urgency=low

  * New upstream version
  * Closes: #304942: ITP: wyrd - ncurses-frontend for remind
  * Update manual page for changed syntax

 -- Rene van Bevern (RvB) <rvb@pro-linux.de>  Tue, 26 Apr 2005 20:47:08 +0200

wyrd (0.1.3-2) unstable; urgency=low

  * use dpatch

 -- Rene van Bevern (RvB) <rvb@pro-linux.de>  Mon, 18 Apr 2005 13:00:39 +0200

wyrd (0.1.3-1) unstable; urgency=low

  * New upstream version
  * reference to pilot-link in manual page
  * ocaml-nox in Build-Depends suffices

 -- Rene van Bevern (RvB) <rvb@pro-linux.de>  Sun, 17 Apr 2005 11:13:16 +0200

wyrd (0.1.2-1) unstable; urgency=low

  * Initial Release.

 -- Rene van Bevern (RvB) <rvb@pro-linux.de>  Sat, 16 Apr 2005 18:01:00 +0200