1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68
|
STAMP_DIR = stampdir
DEF_SUBDIRS=rstart smproxy xsm
SUBDIRS=$(DEF_SUBDIRS)
CONFIG_STAMPS = $(addprefix $(STAMP_DIR)/configure-, $(SUBDIRS))
BUILD_STAMPS = $(addprefix $(STAMP_DIR)/build-,$(SUBDIRS))
%:
dh $@ --with quilt,autotools-dev --parallel
override_dh_auto_configure: $(CONFIG_STAMPS)
$(STAMP_DIR)/configure-%:
mkdir -p $(STAMP_DIR)
dh_auto_configure -D$* -B$*-build -- \
--disable-silent-rules \
--with-rsh=rsh \
$(shell DEB_CFLAGS_MAINT_APPEND=-Wall dpkg-buildflags --export=configure)
>$@
override_dh_auto_build: $(BUILD_STAMPS)
$(STAMP_DIR)/build-%:
dh_auto_build -D$* -B$*-build
>$@
override_dh_auto_clean: $(addprefix clean-, $(SUBDIRS))
rm -rf $(STAMP_DIR)
clean-%:
dh_auto_clean -D$* -B$*-build
override_dh_auto_install:
for FILE in $(SUBDIRS); do \
cd "$$FILE"-build && $(MAKE) DESTDIR=$(CURDIR)/debian/tmp install ; \
cd ..; \
done
find debian/tmp/usr/lib/*/X11/rstart/commands -type f ! -name '@*' -print0 | xargs -0 chmod +x
override_dh_install:
dh_install --fail-missing
.PHONY: get-tarballs
get-tarballs: $(addprefix get-tarball-,$(SUBDIRS))
.PHONY: get-tarball-%
get-tarball-%:
uscan --no-conf --destdir . --download --no-symlink --package $* --upstream-version $(shell awk -F = '/^PACKAGE_VERSION=/ { print $$2 }' < $*/configure ) --watchfile debian/watch.$* || test $$? = 1
.PHONY: update-copyright
update-copyright: $(addsuffix /COPYING, $(SUBDIRS)) debian/copyright.head
cp debian/copyright.head debian/copyright
for subdir in $(SUBDIRS); do \
echo >> debian/copyright && \
echo $$subdir: >> debian/copyright && \
sed -e 's/^./ &/' < $$subdir/COPYING >> debian/copyright \
|| exit; done
|