1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103 104 105 106 107 108 109 110 111 112 113 114 115 116 117 118 119 120 121
|
PACKAGE = xfonts-100dpi
ifneq (,$(filter parallel=%,$(DEB_BUILD_OPTIONS)))
NUMJOBS = $(patsubst parallel=%,%,$(filter parallel=%,$(DEB_BUILD_OPTIONS)))
MAKEFLAGS += -j$(NUMJOBS)
endif
STAMP_DIR = debian/stamps
SUBDIRS = \
font-adobe-100dpi \
font-bh-100dpi \
font-bh-lucidatypewriter-100dpi \
font-bitstream-100dpi
DEB_HOST_ARCH ?= $(shell dpkg-architecture -qDEB_HOST_ARCH)
DEB_HOST_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE)
DEB_BUILD_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE)
ifeq ($(DEB_BUILD_GNU_TYPE), $(DEB_HOST_GNU_TYPE))
confflags += --build=$(DEB_HOST_GNU_TYPE)
else
confflags += --build=$(DEB_BUILD_GNU_TYPE) --host=$(DEB_HOST_GNU_TYPE)
endif
$(STAMP_DIR)/prepare:
mkdir -p $(STAMP_DIR)
dh_update_autotools_config
>$@
$(STAMP_DIR)/build-%: $(STAMP_DIR)/prepare
mkdir -p $*-build
cd $*-build && \
../$*/configure \
--prefix=/usr \
--mandir=\$${prefix}/share/man \
--infodir=\$${prefix}/share/info \
$(confflags)
$(MAKE) -C $*-build GZIP=-n
>$@
build: build-stamp
build-indep: build-stamp
build-stamp: $(addprefix $(STAMP_DIR)/build-,$(SUBDIRS))
>$@
build-arch:
clean:
dh_testdir
rm -f config.cache config.log config.status
rm -f */config.cache */config.log */config.status
rm -f conftest* */conftest*
rm -rf autom4te.cache */autom4te.cache
rm -rf *-build
rm -rf $(STAMP_DIR)
dh_clean
install: build
dh_testdir
dh_testroot
dh_prep
dh_installdirs
set -e; for FILE in $(SUBDIRS); do \
$(MAKE) -C "$$FILE"-build DESTDIR=$(CURDIR)/debian/tmp install; \
done
install -D -m644 debian/fonts.alias \
debian/tmp/etc/X11/fonts/100dpi/xfonts-100dpi.alias
binary-arch: build install
binary-indep: build install
dh_testdir
dh_testroot
dh_installdocs
dh_install --exclude fonts.dir --exclude fonts.scale
dh_missing --fail-missing --exclude fonts.dir --exclude fonts.scale
dh_installxfonts
dh_installchangelogs
dh_compress
dh_fixperms
dh_installdeb
dh_gencontrol
dh_md5sums
dh_builddeb
binary: binary-indep binary-arch
.PHONY: build clean binary-indep binary-arch binary install
.PHONY: get-tarballs
get-tarballs: $(addprefix get-tarball-,$(SUBDIRS))
.PHONY: get-tarball-%
get-tarball-%:
uscan --no-conf --download --no-symlink --destdir . --package $* --upstream-version $(shell awk -F = '/^PACKAGE_VERSION=/ { print $$2 }' < $*/configure || echo 0) --watchfile debian/watch.$* || test $$? = 1
debian/watch.%:
echo version=3 > $@
echo 'https://xorg.freedesktop.org/releases/individual/font/ $*-(.*)\.tar\.gz' >> $@
.PHONY: watchfiles
watchfiles: $(addprefix debian/watch.,$(SUBDIRS))
|