1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60
|
Description: Patch source tests to make them autopkgtest-able
Author: Nick Morrott <nickm@debian.org>
Forwarded: not-needed
Last-Update: 2022-02-01
@@ -27,7 +27,7 @@
my $tests_dir = 't/data'; # directory test files live in
die "no directory $tests_dir" if not -d $tests_dir;
-my $cmds_dir = 'blib/script'; # directory filter programs live in
+my $cmds_dir = $ENV{AUTOPKGTEST_TMP} ? '/usr/bin' : 'blib/script'; # directory filter programs live in
die "no directory $cmds_dir" if not -d $cmds_dir;
my $verbose = 0;
@@ -18,7 +18,7 @@
my $tests_dir = 't/data-tv_imdb'; # where to find input XML files
die "no directory $tests_dir" if not -d $tests_dir;
-my $cmds_dir = 'blib/script'; # directory tv_imdb lives in
+my $cmds_dir = $ENV{AUTOPKGTEST_TMP} ? '/usr/bin' : 'blib/script'; # directory tv_imdb lives in
die "no directory $cmds_dir" if not -d $cmds_dir;
my $verbose = 0;
@@ -21,7 +21,7 @@
my $tests_dir = 't/data'; # where to find input XML files
die "no directory $tests_dir" if not -d $tests_dir;
-my $cmds_dir = 'blib/script'; # directory tv_split lives in
+my $cmds_dir = $ENV{AUTOPKGTEST_TMP} ? '/usr/bin' : 'blib/script'; # directory tv_split lives in
die "no directory $cmds_dir" if not -d $cmds_dir;
my $verbose = 0;
@@ -23,7 +23,7 @@
my $tests_dir = 't/data-tv_augment'; # where to find input XML files
die "no directory $tests_dir" if not -d $tests_dir;
-my $cmds_dir = 'blib/script'; # directory tv_augment lives in
+my $cmds_dir = $ENV{AUTOPKGTEST_TMP} ? '/usr/bin' : 'blib/script'; # directory filter programs live in
die "no directory $cmds_dir" if not -d $cmds_dir;
my $verbose = 0;
@@ -19,7 +19,7 @@
my $tests_dir = 't/data-tv_tmdb'; # where to find input XML files
die "no directory $tests_dir" if not -d $tests_dir;
-my $cmds_dir = 'blib/script'; # directory tv_tmdb lives in
+my $cmds_dir = $ENV{AUTOPKGTEST_TMP} ? '/usr/bin' : 'blib/script'; # directory tv_imdb lives in
die "no directory $cmds_dir" if not -d $cmds_dir;
my $verbose = 0;
|