1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43
|
DEB_HOST_GNU_TYPE := $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE)
VIDEODEP = $(shell cat /usr/share/xserver-xorg/videodrvdep 2>/dev/null)
override_dh_auto_build:
dh_auto_build -- V=1
override_dh_strip:
dh_strip --dbgsym-migration='xserver-xorg-video-qxl-dbg (<< 0.1.4+20161126git4d7160c)'
override_dh_auto_install:
dh_auto_install --destdir=debian/tmp
override_dh_install:
find debian/tmp -name '*.la' -delete
-rm -r debian/tmp/usr/share
install -D -m 644 -o root -g root ./examples/spiceqxl.xorg.conf.example debian/tmp/etc/X11/spiceqxl.xorg.conf
dh_install
override_dh_missing:
dh_missing --fail-missing
override_dh_shlibdeps:
dh_shlibdeps -- --warnings=6
override_dh_xsf_substvars:
echo "xviddriver:Depends=$(VIDEODEP)" >> debian/xserver-xspice.substvars
dh_xsf_substvars
override_dh_auto_configure:
ifeq ($(DEB_HOST_GNU_TYPE), x86_64-linux-gnu)
dh_auto_configure -- --libdir=/usr/lib --enable-xspice
else
dh_auto_configure -- --libdir=/usr/lib
endif
%:
dh $@ --with quilt,xsf,python3 --builddirectory=build/
|