1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103 104 105 106 107 108 109 110 111 112 113 114 115 116 117 118 119 120 121 122 123 124 125 126 127 128 129 130 131 132 133 134 135 136 137 138 139 140 141 142 143 144 145 146 147 148 149 150 151 152 153 154 155
|
export DH_OPTIONS
LC_ALL = C
export LC_ALL
APKG = aspell-eu
AVAR = /var/lib/aspell
ALIB = /usr/lib/aspell
ASHARE = /usr/share/aspell
HPKG = hunspell-eu
HDICTSDIR = /usr/share/myspell/dicts
ASPELL6BASENAME = aspell6-eu
ASPELL6DIR = $(CURDIR)/debian/$(ASPELL6BASENAME)
ASPELLPROC = /usr/share/aspell-lang/proc
DOCS = xuxenedbl.txt xuxenedbl-en.txt xuxenedbl-es.txt
CFLAGS = -Wall -g
ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
CFLAGS += -O0
else
CFLAGS += -O2
endif
configure: configure-stamp
configure-stamp:
dh_testdir
touch configure-stamp
build: build-indep
build-arch: build-arch-stamp
build-arch-stamp: configure-stamp
touch $@
build-indep: build-indep-stamp
build-indep-stamp: configure-stamp
sed '1d' myspell/eu-ES.dic | grep -v -e '[\._]' -e '^katen\-' | prezip -s | gzip -9n -c > eu.cwl.gz
installdeb-hunspell -phunspell-eu
installdeb-aspell -paspell-eu
touch $@
aspelltgz: clean build
mkdir -p $(ASPELL6DIR)/doc
install -m 0644 debian/aspell/Copyright $(ASPELL6DIR)
install -m 0644 debian/aspell/info $(ASPELL6DIR)
install -m 0644 /usr/share/common-licenses/GPL-2 $(ASPELL6DIR)/COPYING
install -m 0644 debian/aspell/eu.dat $(ASPELL6DIR)/eu.dat
install -m 0644 myspell/eu-ES.aff $(ASPELL6DIR)/eu_affix.dat
sed '1d' myspell/eu-ES.dic | grep -v -e '[\._]' -e '^katen\-' | LC_COLLATE=C sort -u | \
aspell --local-data-dir=$(ASPELL6DIR) --lang=eu clean > $(ASPELL6DIR)/eu.wl
( cd $(ASPELL6DIR) && \
ln -sf $(ASPELLPROC) && \
perl proc && \
./configure && \
make dist )
mv $(ASPELL6DIR)/$(ASPELL6BASENAME)*.tar.bz2 ..
clean:
dh_testdir
dh_testroot
rm -f build-arch-stamp build-indep-stamp configure-stamp
rm -f eu.cwl.gz
rm -rf $(ASPELL6DIR)
rm -f hunspell/eu.aff
rm -f hunspell/eu.dic
dh_clean
install: install-common install-indep
install-common:
dh_testdir
dh_testroot
dh_prep
install-indep: build-indep
dh_installdirs -i
install -m 644 myspell/eu-ES.aff debian/$(APKG)/$(ALIB)/eu_affix.dat
install -m 644 eu.cwl.gz debian/$(APKG)/$(ASHARE)
install -m 644 debian/aspell/eu* debian/$(APKG)/$(ALIB)
ln -s eu-ES.aff hunspell/eu.aff
ln -s eu-ES.dic hunspell/eu.dic
installdeb-myspell -phunspell-eu --srcdir=hunspell
install-arch: build-arch
binary-common:
dh_testdir
dh_testroot
dh_installchangelogs
dh_installdocs -A $(DOCS)
dh_installexamples
dh_installman
dh_link
dh_strip
dh_compress
dh_fixperms
dh_makeshlibs
dh_installdeb
dh_shlibdeps
dh_gencontrol
dh_md5sums
dh_builddeb
binary-indep: build-indep install-indep
$(MAKE) -f debian/rules DH_OPTIONS=-i binary-common
binary-arch: build-arch install-arch
binary: binary-indep
.PHONY: build clean binary-indep binary-arch binary install install-indep install-arch configure
|