File: README.md

package info (click to toggle)
yad 0.40.0-1
  • links: PTS
  • area: main
  • in suites: bullseye, buster, sid
  • size: 1,776 kB
  • sloc: ansic: 9,519; sh: 1,270; makefile: 87
file content (39 lines) | stat: -rw-r--r-- 1,641 bytes parent folder | download
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
# Yet Another Dialog
====================

Program allows you to display GTK+ dialog boxes from command line or 
shell scripts. YAD depends on GTK+ only. Minimal GTK+ version is 2.16.0

This software is licensed under the GPL v.3

Project homepage: https://sourceforge.net/projects/yad-dialog/  
Example usage: https://sourceforge.net/p/yad-dialog/wiki/browse_pages/  
Mailing list: http://groups.google.com/group/yad-common

Some miscellaneous stuff can be found in data directory including notify-send script
and simple zenity-compatible wrapper 

# Building git version
======================

Get git version with command

svn checkout svn://svn.code.sf.net/p/yad-dialog/code/trunk yad-dialog-code

Before run the standard ./configure && make && make install procedure
you need to generate build scripts. This can be done by running command

autoreconf -ivf && intltoolize

For successfully build you may need to install the following packages:
* GNU Autotools (https://www.gnu.org/software/autoconf/ http://www.gnu.org/software/automake/)
* Intltool >= 0.40.0 (http://freedesktop.org/wiki/Software/intltool/)
* GTK+ >= 2.16.0 (http://www.gtk.org)
with appropriate *-dev* packages depending on your distro

Additionally, you can build yad with the following libraries:
* Webkit - for supporting HTML dialog (http://webkitgtk.org)
* GtkSourceView - for enabling syntax highlighting in text-info dialog (https://wiki.gnome.org/Projects/GtkSourceView)
* GtkSpell3 - for support spell checking in text fields (http://gtkspell.sourceforge.net/)

Yad can be built angainst both 2 and 3 versions of GTK+ library. Preferred build with version 2