File: changelog

package info (click to toggle)
yapet 2.3-1
  • links: PTS, VCS
  • area: main
  • in suites: bullseye, buster, sid
  • size: 11,868 kB
  • sloc: cpp: 32,400; sh: 5,014; makefile: 880; ansic: 36; sed: 16
file content (311 lines) | stat: -rw-r--r-- 11,899 bytes parent folder | download
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83
84
85
86
87
88
89
90
91
92
93
94
95
96
97
98
99
100
101
102
103
104
105
106
107
108
109
110
111
112
113
114
115
116
117
118
119
120
121
122
123
124
125
126
127
128
129
130
131
132
133
134
135
136
137
138
139
140
141
142
143
144
145
146
147
148
149
150
151
152
153
154
155
156
157
158
159
160
161
162
163
164
165
166
167
168
169
170
171
172
173
174
175
176
177
178
179
180
181
182
183
184
185
186
187
188
189
190
191
192
193
194
195
196
197
198
199
200
201
202
203
204
205
206
207
208
209
210
211
212
213
214
215
216
217
218
219
220
221
222
223
224
225
226
227
228
229
230
231
232
233
234
235
236
237
238
239
240
241
242
243
244
245
246
247
248
249
250
251
252
253
254
255
256
257
258
259
260
261
262
263
264
265
266
267
268
269
270
271
272
273
274
275
276
277
278
279
280
281
282
283
284
285
286
287
288
289
290
291
292
293
294
295
296
297
298
299
300
301
302
303
304
305
306
307
308
309
310
311
yapet (2.3-1) unstable; urgency=medium

  * New upstream version 2.3
  * Update copyright years for debian/* packaging files
  * Refresh avoid-remote-font.patch patch

 -- Salvatore Bonaccorso <carnil@debian.org>  Mon, 25 Feb 2019 08:46:45 +0100

yapet (2.2-3) unstable; urgency=medium

  * Replace home-made GitLab CI with the standard Salsa pipeline
  * Bump Debhelper compat level to 12
  * Declare compliance with Debian policy 4.3.0

 -- Salvatore Bonaccorso <carnil@debian.org>  Fri, 28 Dec 2018 23:41:06 +0100

yapet (2.2-2) unstable; urgency=medium

  * Avoid remote fonts to avoid privacy breach

 -- Salvatore Bonaccorso <carnil@debian.org>  Tue, 06 Nov 2018 09:19:39 +0100

yapet (2.2-1) unstable; urgency=medium

  * GitLab CI/Lintian: install dpkg-dev, that ships dpkg-architecture, needed
    to run some Lintian checks
  * New upstream version 2.2
  * Drop Fix-small-typos-for-Mismatch-word-14.patch

 -- Salvatore Bonaccorso <carnil@debian.org>  Mon, 05 Nov 2018 20:59:05 +0100

yapet (2.1-2) unstable; urgency=medium

  * Declare smoke-test autopkgtest as superficial
  * Fix small typo in binary for "Mismatch" word
  * Update .gitlab-ci.yml based on Salsa CI Team's template

 -- Salvatore Bonaccorso <carnil@debian.org>  Sun, 28 Oct 2018 11:05:32 +0100

yapet (2.1-1) unstable; urgency=medium

  * New upstream version 2.1

 -- Salvatore Bonaccorso <carnil@debian.org>  Sat, 27 Oct 2018 21:36:44 +0200

yapet (2.0-1) unstable; urgency=medium

  * debian/control: Reference new Homepage
  * debian/.gitlab-ci.yml: Update image used for Gitlab CI
  * Declare compliance with Debian policy 4.2.1
  * Use HTTPS transport protocol in watch URL
  * debian/watch: Bump format to version 4.
    Use @PACKAGE@, @ANY_VERSION@ and @ARCHIVE_EXT@ substitutions.
    Simplify watch URL after upstream download page reorganisation.
  * New upstream version 2.0
  * Add Build-Depends on pkg-config
  * Add Build-Depends on libcppunit-dev for unit tests
  * Add Build-Depends on libargon2-dev
  * Refresh do-not-install-licenses-files.patch patch

 -- Salvatore Bonaccorso <carnil@debian.org>  Wed, 24 Oct 2018 00:16:48 +0200

yapet (1.1-1) unstable; urgency=medium

  * Update Vcs-* fields for switch to salsa.debian.org
  * New upstream version 1.1
  * Update copyright years for upstream files
  * Update copyright years for debian/* packaging files
  * Refresh do-not-install-licenses-files.patch patch
  * Drop fix-FTBFS-return-statement-with-a-value.patch patch
  * Drop openssl-1.1.patch patch
  * Add an initial Gitlab CI config file
  * Bump Debhelper compat level to 11
  * Set Rules-Requires-Root to no
  * Declare compliance with Debian policy 4.2.0

 -- Salvatore Bonaccorso <carnil@debian.org>  Tue, 07 Aug 2018 20:59:54 +0200

yapet (1.0-9) unstable; urgency=medium

  * Support building against OpenSSL 1.1 (Closes: #828613)
  * Switch Build-Depends from libssl1.0-dev to libssl-dev.
    Build now by default against OpenSSL 1.1.

 -- Salvatore Bonaccorso <carnil@debian.org>  Sun, 13 Nov 2016 10:24:01 +0100

yapet (1.0-8) unstable; urgency=medium

  * Bump Debhelper compat level to 10
  * Remove --with autoreconf from calls to dh.
    With Debhelper compat level 10 the autoreconf sequence is enabled by
    default.
  * Drop Build-Depends on dh-autoreconf
  * Avoid building with OpenSSL 1.1 for now (Cf. #828613)
  * debian/copyright: change Copyright-Format 1.0 URL to HTTPS
  * debian/rules: Build enabling all hardening flags

 -- Salvatore Bonaccorso <carnil@debian.org>  Sat, 05 Nov 2016 17:59:30 +0100

yapet (1.0-7) unstable; urgency=medium

  * Drop installation of Debian menu file for yapet
  * Declare compliance with Debian policy 3.9.8

 -- Salvatore Bonaccorso <carnil@debian.org>  Fri, 08 Apr 2016 13:55:43 +0200

yapet (1.0-6) unstable; urgency=medium

  * Fix FTBFS with GCC 6: return-statement with a value (Closes: #812017)
  * debian/control: Use HTTPS transport protocol for Vcs-Git URI
  * Update copyright years for debian/* packaging files
  * Declare compliance with Debian policy 3.9.7

 -- Salvatore Bonaccorso <carnil@debian.org>  Thu, 18 Feb 2016 14:07:27 +0100

yapet (1.0-5) unstable; urgency=medium

  * Switch to https for the Vcs-Browser URL
  * Add simple smoke test for autopkgtest

 -- Salvatore Bonaccorso <carnil@debian.org>  Sat, 30 Aug 2014 15:01:49 +0200

yapet (1.0-4) unstable; urgency=medium

  * Add Vcs-Browser and Vcs-Git fields in debian/control file

 -- Salvatore Bonaccorso <carnil@debian.org>  Sat, 02 Aug 2014 20:14:30 +0200

yapet (1.0-3) unstable; urgency=medium

  * Run dh-autoreconf to update config.{sub,guess} and {libtool,aclocal}.m4.
    Replace Build-Depends on autotools-dev with dh-autoreconf and use the
    autoreconf debhelper addon.
    Fixes FTBFS on ppc64el port.
    Thanks to Breno Leitao <brenohl@br.ibm.com> for the patch (Closes: #750694)
  * Refresh do-not-install-licenses-files.patch patch

 -- Salvatore Bonaccorso <carnil@debian.org>  Fri, 06 Jun 2014 11:19:45 +0200

yapet (1.0-2) unstable; urgency=low

  * Upload to unstable

 -- Salvatore Bonaccorso <carnil@debian.org>  Fri, 07 Mar 2014 21:24:10 +0100

yapet (1.0-1) experimental; urgency=medium

  * Imported Upstream version 1.0
  * Remove license information for intl/* files (removed)
  * Update copyright years for debian/* packaging files
  * Update copyright years for upstream files
  * Update comment for m4/* files in debian/copyright
  * Remove separate copyright stanza for ./gettext.h
  * Rename debian/menu to debian/yapet.menu
  * Rename debian/docs to debian/yapet.docs
  * Refresh do-not-install-licenses-files.patch patch
  * Drop fix-spelling-error-in-manpage.patch patch
  * Drop desktop-entry-lacks-keywords-entry.patch patch.
    Keywords were added upstream to the desktop file.
  * Declare compliance with Debian Policy 3.9.5
  * Improve upstream version handling in debian/watch file

 -- Salvatore Bonaccorso <carnil@debian.org>  Mon, 03 Mar 2014 19:48:19 +0100

yapet (0.8~pre2-3) unstable; urgency=low

  * Update debian/copyright file information.
    Update format to copyright-format 1.0 as released together with Debian
    policy 3.9.3.
    Update copyright years for debian/* packaging files.
  * Bump Standards-Version to 3.9.4
  * Update and restore config.sub and config.guess with autotools-dev.
    Use "dh $@ --with autotools_dev" Debhelper addon to update and restore
    config.sub and config.guest during package build. Addresses FTBFS on
    arm64 (aarch64-linux-gnu).
    Thanks to Matthias Klose <doko@debian.org> (Closes: #728011)
  * Add desktop-entry-lacks-keywords-entry.patch patch.
    Add some keywords to the yapet.desktop file.

 -- Salvatore Bonaccorso <carnil@debian.org>  Sun, 27 Oct 2013 18:28:43 +0100

yapet (0.8~pre2-2) unstable; urgency=low

  * Bump Debhelper compat level to 9.
    Adjust Build-Depends on debhelper to (>= 9).
  * Refresh copyright years for debian/* packaging
  * Update format for debian/copyright file.
    Update to revision 174 of format specification in DEP5 proposal for
    machine readable copyright file.
  * Bump Standards-Version to 3.9.2
  * Add fix-spelling-error-in-manpage.patch patch.
    Fix spelling of 'allows to' reported by lintian.
    Thanks to Daniel Kahn Gillmor for helping finding the wording.

 -- Salvatore Bonaccorso <carnil@debian.org>  Tue, 17 Jan 2012 22:10:45 +0100

yapet (0.8~pre2-1) unstable; urgency=low

  * New upstream release
  * Update my email address
  * debian/control: Drop the DM-Upload-Allowed control field.
  * debian/copyright: update copyright years for debian/* packaging.

 -- Salvatore Bonaccorso <carnil@debian.org>  Fri, 11 Feb 2011 21:43:34 +0100

yapet (0.7-2) unstable; urgency=low

  * debian/copyright:
    - Rename field Contact to Maintainer as proposed in revision
      135 of DEP5.
    - Fix typo in abbreviated name for License 'GPL-3+ with OpenSSL
      exception'.
  * debian/NEWS: Add note on new handling of opening password records
    for editing.

 -- Salvatore Bonaccorso <salvatore.bonaccorso@gmail.com>  Thu, 23 Sep 2010 07:50:00 +0200

yapet (0.7-1) unstable; urgency=low

  * New upstream release
  * debian/copyright: Refresh copyright years for upstream files.
  * debian/patches:
    - Drop fix-rng-ftbfs-with-g++4.4.patch as it is applied upstream.
    - Drop 565065-fix-FTBFS-with-gcc-4.5.patch as it is applied upstream.
  * Bump Standards-Version to 3.9.1.

 -- Salvatore Bonaccorso <salvatore.bonaccorso@gmail.com>  Wed, 22 Sep 2010 10:34:10 +0200

yapet (0.6-3) unstable; urgency=low

  * Convert to 3.0 (quilt) package source format. Remove README.source and
    drop use of quilt parameter to dh in rules file.
  * debian/control:
    - Drop Build-Depends on quilt.
    - Update Build-Depends on debhelper (>= 7).
  * Refresh debian/copyright years for debian/* packaging. Referesh file to
    the current format specification of DEP5 for machine readable copyright
    file.
  * Add 565065-fix-FTBFS-with-gcc-4.5.patch to fix FTBFS using
    gcc-4.5/g++-4.5. Thanks Matthias Klose for the bugreport
    (Closes: #565065).

 -- Salvatore Bonaccorso <salvatore.bonaccorso@gmail.com>  Thu, 14 Jan 2010 08:27:43 +0100

yapet (0.6-2) unstable; urgency=low

  * Add fix-rng-ftbfs-with-g++4.4.patch: Fixes FTBFS for yapet rng.cc when
    using gcc-4.4/g++4.4. Thanks again to Martin Michlmayr for reporting this
    issue (Closes: #541093).

 -- Salvatore Bonaccorso <salvatore.bonaccorso@gmail.com>  Thu, 17 Sep 2009 21:37:46 +0200

yapet (0.6-1) unstable; urgency=low

  * New upstream release
    - Fixed serious bug preventing exchange of YAPET files between 32/64
      bit architectures. Please see the NEWS.Debian.gz and README.gz in
      /usr/share/doc/yapet/ for more details (Closes: #543394).
    - /dev/urandom is the default random number generator used for
      generating passwords (Closes: #544140).
    - The random number generator used for generating passwords can be
      selected in the ~/.yapet configuration file.
  * Add README.source to source package as it is rcommended by Debian
    policy since 3.8.0.
  * debian/patches: Refresh do-not-install-licenses-files.patch

 -- Salvatore Bonaccorso <salvatore.bonaccorso@gmail.com>  Fri, 04 Sep 2009 21:49:08 +0200

yapet (0.5-1) unstable; urgency=low

  * New upstream release
  * debian/patches:
    - Refresh do-not-install-licenses-files.patch patch.
    - Drop patches with fixes integrated upstream:
      + fix-ftbfs-with-g++-4.4.patch
      + csv2yapet-delimiter-parsing-bug.patch
      + yapet-load-option-cfgfile-if-suffix-missing.patch
  * Bump Standards-Version to 3.8.3 (no changes).

 -- Salvatore Bonaccorso <salvatore.bonaccorso@gmail.com>  Sun, 23 Aug 2009 18:33:42 +0200

yapet (0.4-2) unstable; urgency=low

  * Add fix-ftbfs-with-g++-4.4.patch patch: Fixes FTBFS for yapet when
    using gcc-4.4/g++-4.4. Thanks to  Martin Michlmayr for reporting
    (Closes: #541093).
  * Fix missing changelog entry for 0.4-1 (Bumped Standards-Version to
    3.8.2).

 -- Salvatore Bonaccorso <salvatore.bonaccorso@gmail.com>  Wed, 12 Aug 2009 19:43:53 +0200

yapet (0.4-1) unstable; urgency=low

  * New upstream release
    - New utility csv2yapet to convert CSV file to YAPET files.
  * debian/patches:
    - Add csv2yapet-delimiter-parsing-bug.patch: Fixes bug causing
      Fields containing the field delimiter in their values make
      csv2yapet misinterpret the CSV file.
    - Add yapet-load-option-cfgfile-if-suffix-missing.patch: The load
      option in the .yapet configuration does not work if the suffix
      .pet in the file path is omitted.
  * debian/control: Bump Standards-Version to 3.8.2 (no changes).

 -- Salvatore Bonaccorso <salvatore.bonaccorso@gmail.com>  Fri, 07 Aug 2009 21:30:49 +0200

yapet (0.3a-1) unstable; urgency=low

  * Initial release (Closes: #532268)

 -- Salvatore Bonaccorso <salvatore.bonaccorso@gmail.com>  Sat, 13 Jun 2009 12:10:34 +0200