1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18
|
Description: quote filename for yahtml-lint-program
Author: KURASHIKI Satoru <lurdan@gmail.com>
Bug-Debian: http://bugs.debian.org/683470
Reviewed-By: Kevin Ryde <user42@zip.com.au>
Index: yatex/yahtml.el
===================================================================
--- yatex.orig/yahtml.el
+++ yatex/yahtml.el
@@ -2827,7 +2827,7 @@ See also yahtml-indent-line-1 and yahtml
(and bcmd (setq bcmd (yahtml-untranslate-string bcmd)))
(YaTeX-typeset
(concat (or bcmd yahtml-lint-program)
- " " (file-name-nondirectory (buffer-file-name buf)))
+ " " (shell-quote-argument file-name-nondirectory (buffer-file-name buf)))
yahtml-lint-buffer "lint" "lint")))
(defun yahtml-file-to-url (file)
|