1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66
|
#! /bin/sh
set -e
case "$1" in
configure)
if [ "@APPLICATION@" = "wiki" ] ; then
chown yaws:yaws /var/lib/yaws-@APPLICATION@/www
fi
f=yaws-@APPLICATION@.conf
if [ -f /etc/yaws/conf.avail/$f ] && [ ! -f /etc/yaws/conf.d/$f ] ; then
echo "Creating config symlink /etc/yaws/conf.d/$f"
ln -s ../conf.avail/$f /etc/yaws/conf.d/
fi
;;
abort-upgrade|abort-remove|abort-deconfigure)
;;
*)
echo "postinst called with unknown argument \`$1'" >&2
exit 0
;;
esac
if [ -x "/etc/init.d/yaws" ]; then
if [ -x "`which invoke-rc.d 2>/dev/null`" ]; then
invoke-rc.d yaws restart || exit $?
else
/etc/init.d/yaws restart || exit $?
fi
fi
exit 0
|