1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34
|
UPSTREAM_GIT := https://opendev.org/openstack/zaqar-tempest-plugin
include /usr/share/openstack-pkg-tools/pkgos.make
%:
dh $@ --buildsystem=pybuild --with python3
override_dh_auto_clean:
python3 setup.py clean
find . -type d -name __pycache__ -exec rm -r {} \+
rm -rf build *.egg-info
override_dh_auto_test:
echo "Do nothing..."
override_dh_auto_install:
echo "Do nothing..."
override_dh_auto_build:
echo "Do nothing..."
override_dh_install:
pkgos-dh_auto_install --no-py2 --in-tmp
dh_install
dh_missing --fail-missing
override_dh_python3:
dh_python3 --shebang=/usr/bin/python3
|