File: changelog

package info (click to toggle)
zipper.app 1.5-3
  • links: PTS, VCS
  • area: main
  • in suites: bookworm, bullseye, buster, sid
  • size: 616 kB
  • sloc: objc: 3,829; makefile: 21; sh: 9
file content (165 lines) | stat: -rw-r--r-- 5,064 bytes parent folder | download
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83
84
85
86
87
88
89
90
91
92
93
94
95
96
97
98
99
100
101
102
103
104
105
106
107
108
109
110
111
112
113
114
115
116
117
118
119
120
121
122
123
124
125
126
127
128
129
130
131
132
133
134
135
136
137
138
139
140
141
142
143
144
145
146
147
148
149
150
151
152
153
154
155
156
157
158
159
160
161
162
163
164
165
zipper.app (1.5-3) unstable; urgency=medium

  * Team upload.
  * debian/control: drop suggests on zoo. (Closes: #885500)

 -- Gürkan Myczko <gurkan@phys.ethz.ch>  Thu, 10 Jan 2019 09:24:27 +0100

zipper.app (1.5-2) unstable; urgency=medium

  * Team upload.
  * debian/Zipper.desktop: improved.
  * debian/menu: dropped.
  * Updated Vcs links.
  * Bump debhelper version to 11.
  * Bump standards version to 4.2.1.

 -- Gürkan Myczko <gurkan@phys.ethz.ch>  Wed, 12 Sep 2018 07:52:11 +0200

zipper.app (1.5-1) unstable; urgency=medium

  * New upstream release:
    - Compatible with current GNUstep (Closes: #749807).
  * debian/control (Maintainer): Adopt the package on behalf of the
    GNUstep team (Closes: #454456).
    (Uploaders): Add myself.
    (Section): Change to `gnustep' to match the override.
    (Build-Depends): Remove librenaissance0-dev.  Require gnustep-make
    (>= 2.6.6-2), debhelper (>= 9) and libgnustep-gui-dev (>= 0.24).
    Add imagemagick for the icon conversion.
    (Homepage): Change to the new GAP home.
    (Vcs-Git, Vcs-Browser): New fields.
    (Depends): Add ${misc:Depends} and ${gnustep:Depends}.
    (Recommends): Demote to Suggests and add more archivers.
    (Conflicts, Replaces): Remove.
    (Description): Extend.
    (Standards-Version): Claim compliance with 3.9.5 as of this release.
  * debian/compat: Bump to 9.
  * debian/patches/gcc-4.7.patch: Remove; fixed upstream.
  * debian/patches/series: Update.
  * debian/rules: Rewrite to use modern debhelper.  Move Resources to
    /usr/share/GNUstep.
  * debian/lintian-override:
  * debian/dirs: Delete.
  * debian/menu: Add icon and longtitle.
  * debian/Zipper.desktop: Make it valid, use full path for the icon, add
    Keywords field.
  * debian/watch: Amend for the new upstream location.
  * debian/install:
  * debian/preinst: New file.
  * debian/copyright: Rewrite in format 1.0 and new copyright/license.

 -- Yavor Doganov <yavor@gnu.org>  Thu, 24 Jul 2014 23:34:15 +0300

zipper.app (1.3-2.1) unstable; urgency=low

  * Non-maintainer upload.
  * gcc-4.7: Fix build failure with GCC 4.7.  Closes: #667876.
    - ZipperDocument.m: sel_eq replaced by sel_isEqual.

 -- Matej Vela <vela@debian.org>  Wed, 23 May 2012 11:02:09 +0100

zipper.app (1.3-2) unstable; urgency=low

  * Upload to unstable.

 -- Gürkan Sengün <gurkan@phys.ethz.ch>  Thu, 03 Jul 2008 10:01:16 -0400

zipper.app (1.3-1) experimental; urgency=low

  * New upstream version.
  * GNUstep transition.
  * Updated my email address.
  * Moved homepage field.

  [Hubert Chathi]
  * Fix recommends for p7zip.

 -- Gürkan Sengün <gurkan@phys.ethz.ch>  Thu, 17 Apr 2008 08:19:26 +0200

zipper.app (1.2-2) unstable; urgency=low

  * GNUstep transition.
    + Updated debian/rules.
    + Updated debian/dirs.
  * Added a desktop file.

 -- Gürkan Sengün <gurkan@linuks.mine.nu>  Tue, 23 Oct 2007 12:35:26 +0200

zipper.app (1.2-1) unstable; urgency=low

  * New upstream version. (Closes: #315281)
  * Added debian/watch.
  * Added supported archivers to Recommends.

 -- Gürkan Sengün <gurkan@linuks.mine.nu>  Tue, 22 May 2007 13:02:39 +0200

zipper.app (1.1-3) unstable; urgency=low

  * Rebuild against latest libgnustep-gui.
  * Updated build depends.
  * Bump standards version.

 -- Gürkan Sengün <gurkan@linuks.mine.nu>  Wed, 20 Sep 2006 20:12:10 +0200

zipper.app (1.1-2) unstable; urgency=low

  * Rebuild against latest libgnustep-gui.
  * Updated build depends.

 -- Gürkan Sengün <gurkan@linuks.mine.nu>  Fri, 20 Jan 2006 14:00:31 +0100

zipper.app (1.1-1) unstable; urgency=low

  * New upstream version.
    + Opens zip archives with comments. (closes: #315284)
  * Updated manual page.
  * Updated standards version.

 -- Gürkan Sengün <gurkan@linuks.mine.nu>  Mon, 28 Nov 2005 11:07:55 +0100

zipper.app (1.0-1) unstable; urgency=low

  * New upstream version.
  * Added Co-Maintainers.
  * Fixed version number in infopanel.

 -- Gürkan Sengün <gurkan@linuks.mine.nu>  Sun, 10 Apr 2005 18:27:10 +0200

zipper.app (0.9-1) unstable; urgency=low

  * New upstream version.
  * Renamed source package to zipper.app.
  * Updated manual page.
  * Fixed debian/copyright.
  * Removed some old and unused stuff from debian/.
  * Updated debian/control build-depends for GNUstep 0.9.4.

 -- Gürkan Sengün <gurkan@linuks.mine.nu>  Wed, 10 Nov 2004 23:40:33 +0100

zipper (0.8-1) unstable; urgency=low

  * New upstream version.
  * Renamed binary package to zipper.app.
  * Updated debian/control build-depends.

 -- Gürkan Sengün <gurkan@linuks.mine.nu>  Fri, 23 Jul 2004 02:06:41 +0200

zipper (0.7-1) unstable; urgency=low

  * New upstream version.
  * Updated debian/zipper.sh. (closes: #245722)

 -- Gürkan Sengün <gurkan@linuks.mine.nu>  Wed, 19 May 2004 19:04:42 +0200

zipper (0.4-2) unstable; urgency=low

  * Fixed a missing depends.

 -- Gürkan Sengün <gurkan@linuks.mine.nu>  Fri, 23 Apr 2004 00:57:06 +0200

zipper (0.4-1) unstable; urgency=low

  * Initial Release.

 -- Gürkan Sengün <gurkan@linuks.mine.nu>  Fri, 16 Jan 2004 12:56:48 +0100