1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68
|
VERSION=$(shell expr "`dpkg-parsechangelog 2>/dev/null |grep Version:`" : '.*Version: \(.*\)')
POD2MAN=pod2man -c Debhelper -r "$(VERSION)"
build-indep:
$(POD2MAN) dh_installzope dh_installzope.1
$(POD2MAN) dh_installzopeinstance dh_installzopeinstance.1
for p in autoscripts/*-dzproduct; do \
e=$$(echo $$p | sed 's/dzproduct/dzextension/'); \
sed 's/product/extension/g' $$p > $$e; \
done
build-arch:
build: build-indep build-arch
clean:
dh_testdir
dh_testroot
rm -f dh_installzope.1
rm -f dh_installzopeinstance.1
rm -f autoscripts/*-dzextension
dh_clean
install: build
dh_testdir
dh_testroot
dh_clean -k
dh_installdirs \
usr/bin \
usr/share/man/man1 \
usr/share/debhelper/autoscripts
cp -p dh_installzope debian/zope-debhelper/usr/bin/
cp -p dh_installzope.1 debian/zope-debhelper/usr/share/man/man1/
cp -p dh_installzopeinstance debian/zope-debhelper/usr/bin/
cp -p dh_installzopeinstance.1 debian/zope-debhelper/usr/share/man/man1/
cp -p autoscripts/* debian/zope-debhelper/usr/share/debhelper/autoscripts/
binary-indep: build install
dh_testdir
dh_testroot
dh_installchangelogs
dh_installdocs
dh_compress
dh_fixperms
dh_installdeb
dh_perl
dh_gencontrol
dh_md5sums
dh_builddeb
binary-arch: build install
binary: binary-indep binary-arch
.PHONY: build-indep build-arch build binary-indep binary-arch binary install clean
|