File: tox.ini

package info (click to toggle)
zope.schema 4.4.2-3
  • links: PTS, VCS
  • area: main
  • in suites: buster, stretch
  • size: 664 kB
  • ctags: 1,464
  • sloc: python: 5,927; xml: 1,283; makefile: 127
file content (45 lines) | stat: -rw-r--r-- 1,106 bytes parent folder | download | duplicates (2)
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
[tox]
envlist = 
# Jython support pending 2.7 support, due 2012-07-15 or so.  See:
# http://fwierzbicki.blogspot.com/2012/03/adconion-to-fund-jython-27.html
#   py26,py27,py32,jython,pypy,coverage
    py26,py27,py32,py33,py34,pypy,coverage,docs

[testenv]
deps =
    zope.schema[test]
commands = 
    python setup.py test -q

[testenv:jython]
commands = 
   jython setup.py test -q

[testenv:coverage]
basepython =
    python2.6
commands = 
#   The installed version messes up nose's test discovery / coverage reporting
#   So, we uninstall that from the environment, and then install the editable
#   version, before running nosetests.
    pip uninstall -y zope.schema
    pip install -e .
    nosetests --with-xunit --with-xcoverage
deps =
    zope.schema[test]
    zope.interface>=3.6.0
    zope.event
    zope.testing
    nose
    coverage
    nosexcover

[testenv:docs]
basepython =
    python2.6
commands = 
    sphinx-build -b html -d docs/_build/doctrees docs docs/_build/html
    sphinx-build -b doctest -d docs/_build/doctrees docs docs/_build/doctest
deps =
    zope.interface>=3.6.0
    Sphinx